0 支持
(160 ポイント)
編集

[20200907]状況の動画を追記します。
https://i.gyazo.com/dfd85aa710af55d685e346d9aecf7957.mp4

MUNの利用を検討をして、技術情報のチュートリアルを進めています。
複数のクライアントを立ち上げ、それぞれが個別に操作ができて制御されるところまでは確認しました。

http://www.monobitengine.com/doc/mun/contents/Tutorial/EnableIsMineControl.htm

サンプルソースをコピペなどして色々、確認しましたが、現在、以下の不具合があります。

パターン1:

1.クライアントを一つ立ち上げ、ルーム作成して入る

2.キャラクターを移動する

3.もう一つ、クライアントを立ち上げ、同じルームに入る

すると、あとから立ち上げたクライアントでのキャラクターの位置に最初に立ち上げたクライアントが重なる(位置が初期化されて最初のクライアントのキャラクター位置がずれる)

パターン2:

1.クライアントを一つ立ち上げ、ルーム作成して入る

2.もう一つ、クライアントを立ち上げ、同じルームに入る

3.片方だけ動かしても、各クライアントで観たキャラクターの位置が合わない。

念のためキャラクターを別レイヤにしてCollisionを切りましたが同じでした。サンプルに入ってるノンプログラミングサンプルはうまく動作するため、何等か設定等の問題と認識しています。

http://www.monobitengine.com/doc/mun/contents/Sample/NonProgramming.htm

何か問題を探るにあたり、可能性のある部分が判ると修正できるのですが、見つけられていません。何かヒントがありましたら教えていただけると幸いです。

Unity2019.4.9

MUN2.8.0 

Windows10

回答 2

0 支持
(160 ポイント)
同じシーンに別サンプルで使ったUnity-chanを入れると同期しました。Amimatorで☑AppliRootMotionで移動する仕組みのキャラクターなのですが、それだとうまくいかないようにも見えます。
(1.6k ポイント)
元スレッドの内容では位置同期がなされていないように見受けられますが、上述のサンプルにおけるキャラクタの位置情報とアニメーション情報は連動して同期しているわけではないので、そこが原因ではないと思います。
(160 ポイント)
ご回答ありがとうございます。サンプルのところがポイントと思いあづレスを貼りましたが、その後のここまで進めての結果です。
http://www.monobitengine.com/doc/mun/contents/Tutorial/TestFailedMultiPlay.htm
連動する実装は一応、している状況です。
0 支持
(1.6k ポイント)
編集
可能性としていくつかあるとは思うのですが、そのページの段階以前に設定した

プレイヤーのプレハブ化
https://bit.ly/3bA6wYK

でプレハブを作成したあと、SceneHierarchyの「Player」を削除し忘れていないでしょうか?

あるいはプレハブ化したPlayerのMonobitViewIDが固定化されていないでしょうか?(プレハブ化したPlayerのMonobitViewコンポーネントのスクリーンショットを https://imgur.com/ などで共有していただけると状況が分かりやすくなるので助かります)
(160 ポイント)
ご回答ありがとうございました。動画を追加いたしますのでご覧いただければと思います。
(1.6k ポイント)
動画拝見しました。付け加えて、こちらでも「組み込み手順に誤りがあった場合」にほぼ同じ現象を再現させることができましたので、おそらく問題の解決につながるかと思います。

原因の推測:
現時点で Player のプレハブの Root に Monobit Transform View が登録されており、その影響で Player の子である Dude を動かしているからだと思われます

以下の点を確認してください。
1. プレハブ化した Player の Root に MonobitView が存在していること
2. 上記の MonobitView の Observed Component Registration List 内に
  Dude (MonobitTransformView)
  Dude (MonobitAnimatorView)
 が登録されていること
3. プレハブ化された Player の子 Dude に MonobitView が存在せず、かつMonobitTransformVIew, MonobitAnimatorView の2つが存在していること

おそらく上記3点のいずれかが満たされていない状態だと思いますので、その場合直接プレハブデータを編集するか、もともと存在する Bearpocalypse.unity のシーンを開き
http://www.monobitengine.com/doc/mun/contents/Tutorial/AddSynchronizedComponent.htm
の手順をやり直してプレハブを作り直されたほうがよろしいかと
(160 ポイント)
編集
ご回答ありがとうございます。

Playerのコンポーネントです。
https://i.gyazo.com/12c9d852bc7312433b88c914ee099583.png
子になっているDudeのコンポーネントです。
https://i.gyazo.com/2d79a620b45f12af59fb8d130ae6d970.png

念のため、それぞれ、エディタで起動後にScene内へロードされたもので撮りました。
Metaが崩れている可能性もあるのでReimportもしていますが同様でした。
一応、ご指摘の部分は出来ていると思われるので、再度、やり直してみます。
ありがとうございました。
(1.6k ポイント)
Player, Dude ともに見えている範囲内では全く問題ないですね。

位置情報のズレ自体は、先に確認したところ何らかの影響により
「PlayerのRootのTransform情報が子Dudeに反映されてしまう」
「PlayerのDudeのTransform情報が親Rootに反映されてしまう」
のいずれか一方が発生する場合、動画の状態とまったく一致した位置ズレを再現できたのですが。その現象が起きていないとも考えられないのですが、貼っていただいた画像の設定では症状の発生が考えられないので詰みですね。

MonobitTransformVIewのスクリプト(Assets/Monobit Unity Networking/Plugins/MonobitNetwork/MonobitTransformView.cs)に記載されている内容を見る限り、単に通信を使ってTrasnform情報を一致させるだけなので、よほど変な仕込みをしていない限り「特定のオブジェクトの位置がずれて相手側に反映される」ということはないはずです。Playerのプレハブ上のどこかに問題があるのは間違いないとは思うのですが…。

もし解決しない場合には、Playerのプレハブ単体(差し支えなければプロジェクト一式)をGoogleDriveなどで共有していただけるなら問題の原因特定に繋がるような気がします。
...